Leben CS600 speaker balance issue

#1
Hello,

Lately I've had to adjust the balance on my Leben (to about the 10:30 position) to maintain a centre image. This is happening with both digital and vinyl playback. I have swapped power tubes and re measured speaker layout.

Any thoughts as to the issue?
Diagnostic procedures?
 
#4
Well without a schematic I will be guessing that bad or dirty Balance pot/volume pot? Or one channel power supply problem that causing a uneven supply voltage.
 
#5
I believe the CS600 shares the power supply rails between both channels so it probably is not a voltage issue. Do others experience the same channel imbalance that you do? I ask because I have dealt with a number of situations over the years where the imbalance turned out to be the listener's ears and not the equipment! Some folks produce enough wax to occlude the canal sufficiently to reduce the perceived amplitude.
 

Wntrmute2

Junior Member
#7
I believe the CS600 shares the power supply rails between both channels so it probably is not a voltage issue. Do others experience the same channel imbalance that you do? I ask because I have dealt with a number of situations over the years where the imbalance turned out to be the listener's ears and not the equipment! Some folks produce enough wax to occlude the canal sufficiently to reduce the perceived amplitude.
That happened to me. I was constantly altering the balance to produce a louder left channel. Finally I went to an ENT and my ears were liDed with wax. Left worse than right. Fixed my balance problem instantly.
 
Top