More 2-way Altecs

jmathers

Junior Member
I recently acquired a pair of Altec 414-16As off CL for a decent price, and figured I'd try to find some decent horns to pair up with them. Once I had the woofers it didn't take me long to run across the JE Labs blog and read JE's posts about his 2-way Altec project.

I managed to find a set of 909-16A drivers and a pair of 32b horns off ebay. And with great luck a local audiophile/mad scientist had a pair of Altec 614 cabinets for a phenomenal price.
And all this came together in about two weeks.

I ordered mock up parts (poly caps) for JE's N1600 crossover and got it all singing in less than a month. I've since replaced all the polys with paper-in-oils and found much improvement. Still dialing everything in but I'm enjoying the sound - dynamic, rich, alive.

Thanks to all the Altec fanatics out there for the help and encouragement.



https://photos.app.goo.gl/idiJjUZgKEfzTeSD2



https://photos.app.goo.gl/Sl2EN0UtkpbcYayx2
 
Last edited:

Redboy

Knobophobe
Nuts, I can't see the pics.

I'm working on a similar project, but it's progressed at a glacial pace. Typical, here.
 

jmathers

Junior Member
Which amps do you prefer?
Good question! I was able to try a wonderful 45 amp (built by Redboy) that I borrowed from Olson. I thought initially with this amp that I needed a little more power but I think that not to be the case after some experimentation. And I tried an Almarro A205 EL84 integrated that I thought sounded excellent and was about the right wattage for me.

I'd like to try more single-ended amps - I'm searching for one now (or thinking about building one this winter maybe).

I only have either an AES AE-25 Superamp (about 25 watts) or AES Sixpac monoblocks (about 60 watts) otherwise. Both are much more powerful than what I need but I'm still enjoying them with the preference right now for the smaller powered Superamp.
 
Last edited:

jmathers

Junior Member
Nuts, I can't see the pics.

I'm working on a similar project, but it's progressed at a glacial pace. Typical, here.
My usual project speed is glacial. This fell together with serendipity for some reason.

It's not without some issues though. For whatever reason one of the horn drivers appears to be significantly louder than the other. I've tried to troubleshoot by swapping drivers around and checking the outer cover wiring - I did have to make a couple of repairs to the wire connection - but I still can't fully comprehend it. They weren't a "matched pair" of drivers. They measure around 10 ohms for one and the other about 8 ohms. Seems an insignificant difference to me to account for the volume difference. But I'll keep troubleshooting.

Don't know why you can't see the pics???
 

TubeHiFiNut

Administrator
My usual project speed is glacial. This fell together with serendipity for some reason.

It's not without some issues though. For whatever reason one of the horn drivers appears to be significantly louder than the other. I've tried to troubleshoot by swapping drivers around and checking the outer cover wiring - I did have to make a couple of repairs to the wire connection - but I still can't fully comprehend it. They weren't a "matched pair" of drivers. They measure around 10 ohms for one and the other about 8 ohms. Seems an insignificant difference to me to account for the volume difference. But I'll keep troubleshooting.

Don't know why you can't see the pics???
Have you checked the diaphragms?

Maybe one original and one after market?
 

jmathers

Junior Member
Have you checked the diaphragms?

Maybe one original and one after market?
I'm not sure I'd be able to tell the difference if they were in my hands. That is, they look identical from the top. Maybe I'll take some pics and see what yous guys think. Anyway that would explain the difference....
 

Redboy

Knobophobe
Added some direct links to the pics in the first post.
Thank you. The links work but for some reason the embedded images won’t display. Must be one of my settings.

Your cabinets look great! Nice work on the crossovers, too.

I’ll be interested to see how things progress.
 

airdronian

Junior Member
Very nice job.

I gave up on Google Photos for embedded urls (although I use the service all the time) because of this kind of inconsistency.
 

Punker X

Junior Member
Same here couldn't see the pictures, had to hit the links. Also have have never been able link a picture successfully form Google photos.

Looks great Jeff, love to have a listen sometime.
 
Top